Clan XA - Xtreme Assassins

General Category => Server complaints/ Suggestions => Topic started by: =XA= devish on January 16, 2018, 02:58:53 PM

Title: Mouse drift in CS/XA server
Post by: =XA= devish on January 16, 2018, 02:58:53 PM
I've brought this up in the CS server a few times and gotten lots of responses from people claiming to have the exact same issue. 

Basically for the last week I've been expiring mouse drift in the server.  Like it suddenly drifts off to one side or another without my input.   I haven't tested too much in other servers.. but many other players have confirmed this as well.  I'm not sure if this is a windows update or something going on with the game or our server.  I was hoping for some feedback from you all.  Anyone know if any changes made to the server in the past 7-14 days?

Several players in our servers have gone out and buying a new mouse thinking it was their setup..  One user claimed he was running a MAC and had the same problem...  I'm running Win10 so not sure if the recent Spectre patching has anything to do with it.

Whats your setup and do you have this issue in other server/games? 


Title: Re: Mouse drift in CS/XA server
Post by: =XA= devish on January 16, 2018, 03:02:49 PM
I'm wondering if it happens right when someone specs you...
Title: Re: Mouse drift in CS/XA server
Post by: =XA= Chuck on January 16, 2018, 05:26:49 PM
My mouse was doing funny moment after a windows update a few weeks ago I googled for hours and found the fix.

In game options under mouse settings click "Raw mouse input"  and sure enough it fixed it for me.  try it
Title: Re: Mouse drift in CS/XA server
Post by: =XA= TiRant on January 16, 2018, 07:20:50 PM
I've brought this up in the CS server a few times and gotten lots of responses from people claiming to have the exact same issue. 

Basically for the last week I've been expiring mouse drift in the server.  Like it suddenly drifts off to one side or another without my input.   I haven't tested too much in other servers.. but many other players have confirmed this as well.  I'm not sure if this is a windows update or something going on with the game or our server.  I was hoping for some feedback from you all.  Anyone know if any changes made to the server in the past 7-14 days?

Several players in our servers have gone out and buying a new mouse thinking it was their setup..  One user claimed he was running a MAC and had the same problem...  I'm running Win10 so not sure if the recent Spectre patching has anything to do with it.

Whats your setup and do you have this issue in other server/games?

I've been having this exact issue since I swapped to a USB mouse. Happens in every server.

Redragon M601 Gaming Mouse wired with red led, 3200 DPI 6 Buttons Ergonomic CENTROPHORUS Gaming Mouse for PC
Title: Re: Mouse drift in CS/XA server
Post by: =XA= Chuck on January 16, 2018, 07:42:17 PM
I've brought this up in the CS server a few times and gotten lots of responses from people claiming to have the exact same issue. 

Basically for the last week I've been expiring mouse drift in the server.  Like it suddenly drifts off to one side or another without my input.   I haven't tested too much in other servers.. but many other players have confirmed this as well.  I'm not sure if this is a windows update or something going on with the game or our server.  I was hoping for some feedback from you all.  Anyone know if any changes made to the server in the past 7-14 days?

Several players in our servers have gone out and buying a new mouse thinking it was their setup..  One user claimed he was running a MAC and had the same problem...  I'm running Win10 so not sure if the recent Spectre patching has anything to do with it.

Whats your setup and do you have this issue in other server/games?

I've been having this exact issue since I swapped to a USB mouse. Happens in every server.

Redragon M601 Gaming Mouse wired with red led, 3200 DPI 6 Buttons Ergonomic CENTROPHORUS Gaming Mouse for PC

Have you tried  "Raw mouse input"
Title: Re: Mouse drift in CS/XA server
Post by: =XA= placeb0 on January 16, 2018, 09:19:47 PM
Mine has been doing this exact thing for a few weeks now.

No consistent pattern as to when it does it, but it will just take off, very smoothly.

Guess I will give the Raw Mouse a try.


Unlike a raw dog.
Title: Re: Mouse drift in CS/XA server
Post by: =XA= riley on January 17, 2018, 10:13:26 AM
This isn't a issue with the server.
Title: Re: Mouse drift in CS/XA server
Post by: =XA= JVRacer04 on February 01, 2018, 12:30:39 PM
Ive had the exact same issue, I thought it was drivers for my mouse which i updated maybe a month back. Ill try the raw input and see what it does
Title: Re: Mouse drift in CS/XA server
Post by: =XA= TiRant on February 01, 2018, 01:08:09 PM
Ive had the exact same issue, I thought it was drivers for my mouse which i updated maybe a month back. Ill try the raw input and see what it does

It fixed it for me.
Title: Re: Mouse drift in CS/XA server
Post by: d4rk on February 01, 2018, 04:55:54 PM
Same issue happened to me this month with the new Windows 10 update. In options check the box raw input under mouse and it fixed it for me.
Title: Re: Mouse drift in CS/XA server
Post by: =XA= Chuck on February 01, 2018, 05:44:01 PM
Thanks Chuck your the man. WOW I should have listen to Chuck he knows whats he's talking about. WOW if I have any problems I'll just ask Chuck he's the man.

OK LOL  Done patting myself on the back.  But sometimes it pays to listen to the OLD man.  lol

Title: Re: Mouse drift in CS/XA server
Post by: =XA= Bl^st on February 02, 2018, 09:31:46 AM
I thought MOST people already used raw input?
Title: Re: Mouse drift in CS/XA server
Post by: =XA= TiRant on February 02, 2018, 01:08:03 PM
I thought MOST people already used raw input?

I didn't. I don't think I ever did, in fact. There's a subtle change in the response that takes a little getting used to.
Title: Re: Mouse drift in CS/XA server
Post by: joltX[dt] on April 26, 2018, 03:03:43 PM
Hi all -- I experience the same issue with my DeathAdder on a QcK+ Heavy mousepad.  The issue is with the optics on the mouse reading movements while your mouse is in the air/slightly off the mat, like when you're turning abruptly or with slow sensitivity.  One of the best ways to solve this is to download the drivers for your mouse.  A lot of times, you can adjust the sensitivity of the optics.  Unfortunately my mouse is also broken so I cannot fix the issue but hopefully this is somewhat helpful for others.

Also, try installing the Mark C (correct me if I'm wrong on the name) Mouse Fix for Windows 7/8/10 which will help with the computers interpretation of your raw mouse input.  This Mouse Fix changes a file in your computers registry, which is normal, and is NOT illegal or unsafe for your computer.

Best,
TJ
Title: Re: Mouse drift in CS/XA server
Post by: =XA= mont on April 26, 2018, 03:06:12 PM
m_rawinput 1 fixed the mouse drift for me.

And I used to use the cpl_mousefix so that my mouse's sensitivity would drastically drop on my desktop but I don't think it works on windows 10. Don't notice that much of a difference when I did it on my last reformat.
Title: Re: Mouse drift in CS/XA server
Post by: =XA= Balance on April 26, 2018, 11:57:15 PM
Happens all the time to me. 
Title: Re: Mouse drift in CS/XA server
Post by: =XA= devish on April 27, 2018, 11:05:47 AM
I thought MOST people already used raw input?

I didn't. I don't think I ever did, in fact. There's a subtle change in the response that takes a little getting used to.

This is was irritated me.  Raw input fixed the mouse drift issue for me.  But it did cause a slight response or change to your overall sensitivity setting that takes a bit to get used too.  but at least its consistent. 

I did more research on this awhile back and found it was a Microsoft developer patch thats caused this.